Intermittent failures sending email
Incident Report for Preclose
Resolved
Our third-party provider has indicated that this issue is resolved. Please let us know if you experience any issues sending email through Preclose.
Posted Mar 24, 2022 - 08:48 EDT
Investigating
We are aware of an issue that is causing emails to intermittently fail to send. This is due to an issue with one of our providers and we are waiting for them to resolve the issue.
Posted Mar 22, 2022 - 15:33 EDT
This incident affected: Preclose Go (Go website).